$re = '/(\${)(\w+)(\$?})\1(\w+)\3/';
$str = 'anything text1${text2${text3}${text4}text5} anything';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);