$re = '/[a-z ]+/';
$str = 'Regal Crown Center Stadium 14
Regal Crown Center 14 Stadium';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;