#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(?<=\href=")(.*?)(?=\/css)(?<![A-z0-9])"
Local $sString = "<link rel="stylesheet" type="text/css" href="/css/clients.insights.de6509e7.css">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")