#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]+"
Local $sString = "0_topo" & @CRLF & _
"1_rigid" & @CRLF & _
"00_topo" & @CRLF & _
"01_rigid" & @CRLF & _
"000_topo" & @CRLF & _
"003_capri" & @CRLF & _
"topo" & @CRLF & _
"log" & @CRLF & _
"capri" & @CRLF & _
"else"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")