import re
regex = re.compile(r"http(s)?:\/\/media(-test)?\.mein-helix.de[a-zA-Z0-9\/]+\/([\w-+.]*)", flags=re.MULTILINE)
test_str = ("<p>Wir sind ein modernes und dynamisches Unternehmen, das mit starken Produkten am Markt ist. Zur Verstärkung unseres Teams suchen wir ab sofort ein/e Alleskönner/in.</p>\n\n"
"<p><img alt=\"helix-logo-50_1.png\" src=\"https://media-test.mein-helix.de/files/image/2020/09/DydjLfTTupBvdUmFhD0yazQkUJNbx6SU_helix-logo-50_1.png\" /></p>\n\n"
"<p><strong>Ihre Herausforderungen</strong></p>\n\n"
"<p> </p>\n\n"
"<ul>\n"
" <li>Sie analysieren und verstehen die gegenwärtigen Aufgaben, die sich aus den internen Strukturen und den Ansprüchen der Kunden ergeben.</li>\n"
"</ul>\n\n"
"<p> </p>\n\n"
"<ul>\n"
" <li>Sie leiten daraus die idealen Lösungen ab und setzen diese gezielt um.</li>\n"
"</ul>\n\n"
"<p><img alt=\"helix-logo-50_1.png\" src=\"https://media.mein-helix.de/files/image/2020/09/DydjLfTTupBvdUmFhD0yazQkUJNbx6SU_helix-logo-50_1.png\" /></p>\n\n"
"<p> </p>\n\n"
"<ul>\n"
" <li>Sie verwirklichen die Wünsche und Vorstellungen unserer Kunden in bestmöglicher Weise und sorgen so für eine maximale Kundenzufriedenheit.</li>\n"
"</ul>\n\n"
"<p> </p>\n\n"
"<ul>\n"
" <li>Sie finden ständig neue Wege, um die Wirksamkeit unserer Maßnahmen nachhaltig zu steigern.</li>\n"
"</ul>\n\n"
"<p> </p>\n\n"
"<p>jjj</p>\n\n"
"<p><strong>Ihr Profil</strong></p>\n\n"
"<p> </p>\n\n"
"<ul>\n"
" <li>Hohe Komplexität, hohe Ungewissheit und das Fehlen eines vorgegebenen Lösungswegs schrecken sie nicht ab.</li>\n"
"</ul>\n\n"
"<p> </p>\n\n"
"<ul>\n"
" <li>Sie können sich ohne Fachwissen sehr schnell in neue Problembereiche eindenken und lernen schnell.</li>\n"
"</ul>\n\n"
"<p> </p>\n\n"
"<ul>\n"
" <li>Sie können viele verschiedene (auch unkonventionelle) Lösungen generieren und sich trotz unvollständiger und unklarer Information für eine davon entscheiden.</li>\n"
"</ul>\n\n"
"<p> </p>\n\n"
"<ul>\n"
" <li>Sie können sich gut selbst strukturieren.</li>\n"
"</ul>\n\n"
"<p><br />\n"
"Wenn Sie an einer kreativen Arbeitsatmosphäre in einem fantastischen Team, mitten in Bamberg interessiert sind, bewerben Sie sich noch heute online.</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")