// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w{3}\s\d{2}\s\d{2}:\d{2}:\d{2}\s\w+\s\w+\[\d+\]:\squery\[\w+\]\s([\da-z\.-]+\.[a-z]{2,6})\s\w+\s(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})").unwrap();
let string = "Jul 30 00:00:41 rpi dnsmasq[571]: query[A] officescan.corp.arcon.com.br from 192.168.5.187
Jul 30 00:00:43 rpi dnsmasq[571]: query[A] teams.events.data.microsoft.com from 192.168.5.187
Jul 30 00:00:43 rpi dnsmasq[571]: forwarded teams.events.data.microsoft.com to 1.0.0.1
Jul 30 00:00:43 rpi dnsmasq[571]: forwarded teams.events.data.microsoft.com to 1.1.1.1
Jul 30 00:00:43 rpi dnsmasq[571]: reply teams.events.data.microsoft.com is <CNAME>
Jul 30 00:00:43 rpi dnsmasq[571]: reply teams-events-data.trafficmanager.net is <CNAME>
Jul 30 00:00:43 rpi dnsmasq[571]: reply skypedataprdcolweu02.cloudapp.net is 52.114.74.43
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}