$re = '/(dedupMode=")(?:normal|accept|manual|review)(")/m';
$str = '<Operation dedupMode="normal" name="update">';
$subst = "\1manual\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;