#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(:|;){1}(\-|~)?(D|\)){1}$"
Local $sString = ":D" & @CRLF & _
":)" & @CRLF & _
";D" & @CRLF & _
";)" & @CRLF & _
":D" & @CRLF & _
"x)" & @CRLF & _
"" & @CRLF & _
":-D" & @CRLF & _
":0)" & @CRLF & _
";~D" & @CRLF & _
";_)" & @CRLF & _
":D"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")