package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(:|;){1}(\-|~)?(D|\)){1}$`)
var str = `:D
:)
;D
;)
:D
x)
:-D
:0)
;~D
;_)
:D`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}