$re = '/^(:|;){1}(\-|~)?(D|\)){1}$/m';
$str = ':D
:)
;D
;)
:D
x)
:-D
:0)
;~D
;_)
:D';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);