#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d{4}\K\d+"
Local $sString = "99999999" & @CRLF & _
"12345.66" & @CRLF & _
"1234" & @CRLF & _
"" & @CRLF & _
"abc99999999" & @CRLF & _
"99999999abc"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)