$re = '/^(?:\?*[a-zA-Z\d]\?*){2,}\*?$/m';
$str = 'abcd
?bcd
ab??
ab*
ab?*
??cd
*ab
???
ab cd
abcd
a?????b????';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);