$re = '/^(?:\?*[a-zA-Z\d]){2}[a-zA-Z\d?]*\*?$/m';
$str = 'abcd
?bcd
ab??
ab*
ab?*
??cd
a?????b????*
ab cd
*ab
???
ab? cd
ab ?d
ab *
a ? b
abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);