use strict;
my $str = 'text *inner text 1* text2 *inner text 2*';
my $regex = qr/\*([^\*]+)\*/mp;
my $subst = '<span>$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";