// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\*([^\*]+)\*").unwrap();
let string = "text *inner text 1* text2 *inner text 2*";
let substitution = "<span>$1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}