using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\S+\s+up\s+(?<uptime>(?:\S+\s+days,\s+\d+:\d+|\S+\s+min)|\d+:\d+)";
string input = @" 16:37:50 up 18 days, 19:59, load average: 0.23, 0.26, 0.29
11:12:08 up 899 days, 20:35, 2 users, load average: 0.28, 0.29, 0.25
15:19:17 up 22:45, load average: 0.18, 0.31, 0.36
11:11:11 up 12:55, 2 users, load averages: 0.00, 0.01, 0.06
11:11:11 up 55 min, 2 users, load averages: 0.00, 0.01, 0.06
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}