$re = '/^( +)(.*)$/m';
$str = ' sdf
asdasd sdf
ss sdf';
$subst = "<!--$1-->$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;