using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"<div id=""target""((?'nested'<div)|</div(?'-nested')|[\w\W]*?)*</div>";
        string input = @"<!DOCTYPE html>
<html>
	<head>
		<title>someTitle</title>
	</head>
	<body>
		<div class=""outer"">
			<h1>SomeHeader</h1>
			<div id=""target"">
				<h2>anotherHeader</h2>
				<div id=""child"">
					<div id=""grand-child"">
						<h4>HelloWorld</h4>
					</div>
				</div>
			</div>
		</div>
	</body>
</html>";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}