package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\t:]*(from (.*) |)import (.*?)[\n]`)
var str = `import os
from os import test
for i in range(50):import os
import os
for i in range(50):
import os
print("We are importing this new, import ajid.")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}