package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([\w-]{2,50})+([\@]){1}+([\w-]{2,50})+([.]){1}([\w-]{2,10}))$`)
var str = `testtest@gmail.com
testTest@yahoo.fr
123@yahoo.fr
_-@test.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}