const regex = /^(([\w-]{2,50})+([\@]){1}+([\w-]{2,50})+([.]){1}([\w-]{2,10}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([\\w-]{2,50})+([\\@]){1}+([\\w-]{2,50})+([.]){1}([\\w-]{2,10}))$', 'gm')
const str = `testtest@gmail.com
testTest@yahoo.fr
123@yahoo.fr
_-@test.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}