// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<firstName>\p{Lu}\p{Ll}+(?: \p{Lu}\.)?) (?<lastName>\p{L}\p{Ll}+(\p{Pd}\p{Lu})?\p{Ll}+)$").unwrap();
let string = "John Smith
John S. Smith";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}