#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)tzses (.*?) www"
Local $sString = "# Netscape HTTP Cookie File # http://curl.haxx.se/rfc/cookie_spec.html # This file was generated by libcurl! Edit at your own risk. www.timezero.ru FALSE / FALSE 0 tzl Terminal Police www.timezero.ru FALSE / FALSE 0 tzses 10262169020539404289 www.timezero.ru FALSE / FALSE 0 tzsrv city1.timezero.ru www.timezero.ru FALSE / FALSE 0 tzlang ru" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Это ссылка: http://www.tzpolice.ru/interface/cron/cjr.ck" & @CRLF & _
"нужно получить значение tzses" & @CRLF & _
"и записать в переменную для дальнейшей работы..." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")