$re = '/^[a-zA-Z0-9 \(\)\n]*$/';
$str = 'sdf sdf sdf sdf ( ) ()()()
sdlkfj sdlfkj 51651351-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);