using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![A-Z0-9])[A-Z0-9]{20}(?![A-Z0-9])";
string input = @"AY2QIEOSLITEHZ7JAIKA";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}