#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)https:\/\/(lemdro\.id)\/c\/(.*)"
Local $sString = "HtTpS://user:pw@lemdro.id:443/c/dontUseRegexesToParseURLs" & @CRLF & _
"HtTpS://lemdro.id:443/c/dontUseRegexesToParseURLs" & @CRLF & _
"Http://maliciouswebsite.to/?q=https://lemdro.id/c/dontUseRegexesToParseURLs" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")