using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/(lemdro\.id)\/c\/(.*)";
string input = @"HtTpS://user:pw@lemdro.id:443/c/dontUseRegexesToParseURLs
HtTpS://lemdro.id:443/c/dontUseRegexesToParseURLs
Http://maliciouswebsite.to/?q=https://lemdro.id/c/dontUseRegexesToParseURLs
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}