import Foundation
let pattern = #"https:\/\/(lemdro\.id)\/c\/(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
HtTpS://user:pw@lemdro.id:443/c/dontUseRegexesToParseURLs
HtTpS://lemdro.id:443/c/dontUseRegexesToParseURLs
Http://maliciouswebsite.to/?q=https://lemdro.id/c/dontUseRegexesToParseURLs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)