import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/www\\.serrurierparis0\\.com\\/([^ \\n]*)";
final String string = "https://www.serrurierparis0.com/serrurier-paris-1er.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-2eme.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-3eme.html /serrurier-paris-3eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-4eme.html /serrurier-paris-4eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-5eme.html /serrurier-paris-5eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-6eme.html /serrurier-paris-6eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-7eme.html /serrurier-paris-7eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-8eme.html /serrurier-paris-8eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-9eme.html /serrurier-paris-9eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-10eme.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-11eme.html /serrurier-paris-11eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-12eme.html /serrurier-paris-12eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-13eme.html /serrurier-paris-13eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-14eme.html /serrurier-paris-14eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-15eme.html /serrurier-paris-15eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-16eme.html /serrurier-paris-16eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-17eme.html /serrurier-paris-17eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-18eme.html /serrurier-paris-18eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-19eme.html /serrurier-paris-19eme/\n"
+ "https://www.serrurierparis0.com/serrurier-paris-20eme.html /serrurier-paris-20eme/\n"
+ "https://www.serrurierparis0.com/serrurier-antony-92160.html /serrurier-antony-92160/\n"
+ "https://www.serrurierparis0.com/serrurier-bagnolet-93170.html /serrurier-bagnolet-93170/\n"
+ "https://www.serrurierparis0.com/serrurier-bonneuil-sur-marne-94380.html /serrurier-bonneuil-sur-marne-94380/\n"
+ "https://www.serrurierparis0.com/serrurier-chevilly-larue-94550.html /serrurier-chevilly-larue-94550/\n"
+ "https://www.serrurierparis0.com/serrurier-choisy-le-roi-94600.html /serrurier-choisy-le-roi-94600/\n"
+ "https://www.serrurierparis0.com/serrurier-creteil-94000.html /serrurier-creteil-94000/\n"
+ "https://www.serrurierparis0.com/serrurier-drancy-93700.html /serrurier-drancy-93700/\n"
+ "https://www.serrurierparis0.com/serrurier-gennevilliers-92230.html /serrurier-gennevilliers-92230\n"
+ "https://www.serrurierparis0.com/serrurier-ivry-sur-seine-94200.html /serrurier-ivry-sur-seine-94200/\n"
+ "https://www.serrurierparis0.com/serrurier-le-plessis-robinson-92350.html /serrurier-le-plessis-robinson-92350/\n"
+ "https://www.serrurierparis0.com/serrurier-les-lilas-93260.html /serrurier-les-lilas-93260/\n"
+ "https://www.serrurierparis0.com/serrurier-montrouge-92120.html /serrurier-montrouge-92120/\n"
+ "https://www.serrurierparis0.com/serrurier-puteaux-92800.html /serrurier-puteaux-92800/\n"
+ "https://www.serrurierparis0.com/serrurier-romainville-93230.html /serrurier-romainville-93230/\n"
+ "https://www.serrurierparis0.com/serrurier-saint-cloud-92210.html /serrurier-saint-cloud-92210/\n"
+ "https://www.serrurierparis0.com/serrurier-saint-maurice-94410.html /serrurier-saint-maurice-94410/\n"
+ "https://www.serrurierparis0.com/serrurier-sceaux-92330.html /serrurier-sceaux-92330/\n"
+ "https://www.serrurierparis0.com/serrurier-thiais-94320.html /serrurier-thiais-94320/\n"
+ "https://www.serrurierparis0.com/serrurier-villejuif-94800.html /serrurier-villejuif-94800/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-de-chabrol.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-de-la-grange-aux-belles.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-de-l-aqueduc.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-des-recollets.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-d-hauteville.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-du-faubourg-saint-denis.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-du-terrage.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-faubourg-saint-martin.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-la-fayette.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-rue-louis-blanc.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/paris-11-rue-de-charonne.html /serrurier-paris-11eme/\n"
+ "https://www.serrurierparis0.com/paris-12-rue-charenton.html /serrurier-paris-12eme/\n"
+ "https://www.serrurierparis0.com/paris-13-serrurier-rue-tolbiac.html /serrurier-paris-13eme/\n"
+ "https://www.serrurierparis0.com/paris-14-serrurier-rue-alesia.html /serrurier-paris-14eme/\n"
+ "https://www.serrurierparis0.com/paris-15-serrurier-rue-de-lourmel.html /serrurier-paris-15eme/\n"
+ "https://www.serrurierparis0.com/paris-15-serrurier-rue-lecourbe.html /serrurier-paris-15eme/\n"
+ "https://www.serrurierparis0.com/serrurier-romainville-rue-jean-jaures-93230.html /serrurier-romainville-93230/\n"
+ "https://www.serrurierparis0.com/serrurier-romainville-rue-veuve-aublet-93230.html /serrurier-romainville-93230/\n"
+ "https://www.serrurierparis0.com/paris-16-serrurier-rue-de-la-pompe.html /serrurier-paris-16eme/\n"
+ "https://www.serrurierparis0.com/paris-17-serrurier-rue-cardinet.html /serrurier-paris-17eme/\n"
+ "https://www.serrurierparis0.com/paris-17-serrurier-rue-legendre.html /serrurier-paris-17eme/\n"
+ "https://www.serrurierparis0.com/paris-18-serrurier-rue-marcadet.html /serrurier-paris-18eme/\n"
+ "https://www.serrurierparis0.com/paris-19-serrurier-rue-de-crimee.html /serrurier-paris-19eme/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-de-castiglione.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-de-l-amiral-de-coligny.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-des-halles.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-du-louvre.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-du-pont-neuf.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-montmartre.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-rivoli.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-rohan.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-saint-denis.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-rue-saint-honore.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-20-serrurier-rue-des-pyrenees.html /serrurier-paris-20eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-d-aboukir.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-de-clery.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-du-quatre-septembre.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-du-sentier.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-d-uzes.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-leopold-bellan.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-notre-dame-des-victoires.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-poissonniere.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-saint-denis.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-2-serrurier-rue-saint-sauveur.html /serrurier-paris-2eme/\n"
+ "https://www.serrurierparis0.com/paris-3-serrurier-rue-du-vertbois.html /serrurier-paris-3eme/\n"
+ "https://www.serrurierparis0.com/paris-3-serrurier-rue-froissart.html /serrurier-paris-3eme/\n"
+ "https://www.serrurierparis0.com/paris-3-serrurier-rue-saint-martin.html /serrurier-paris-3eme/\n"
+ "https://www.serrurierparis0.com/paris-4-serrurier-rue-de-rivoli.html /serrurier-paris-4eme/\n"
+ "https://www.serrurierparis0.com/paris-4-serrurier-rue-de-turenne.html /serrurier-paris-4eme/\n"
+ "https://www.serrurierparis0.com/paris-4-serrurier-rue-du-temple.html /serrurier-paris-4eme/\n"
+ "https://www.serrurierparis0.com/paris-5-serrurier-rue-saint-jacques.html /serrurier-paris-5eme/\n"
+ "https://www.serrurierparis0.com/paris-6-serrurier-rue-de-rennes.html /serrurier-paris-6eme/\n"
+ "https://www.serrurierparis0.com/paris-7-serrurier-rue-de-l-universite.html /serrurier-paris-7eme/\n"
+ "https://www.serrurierparis0.com/paris-8-serrurier-rue-faubourg-saint-honore.html /serrurier-paris-8eme/\n"
+ "https://www.serrurierparis0.com/paris-9-rue-la-fayette.html /serrurier-paris-9eme/\n"
+ "https://www.serrurierparis0.com/paris-17-serrurier-avenue-de-villiers.html /serrurier-paris-17eme/\n"
+ "https://www.serrurierparis0.com/paris-19-serrurier-avenue-jean-jaures.html /serrurier-paris-19eme/\n"
+ "https://www.serrurierparis0.com/paris-1-serrurier-avenue-du-general-lemonnier.html /serrurier-paris-1er/\n"
+ "https://www.serrurierparis0.com/paris-10-serrurier-boulevard-de-magenta.html /serrurier-paris-10eme/\n"
+ "https://www.serrurierparis0.com/ouverture-porte-paris.html /ouverture-de-porte/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-1.html /ouverture-de-porte-paris-1/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-10.html /ouverture-de-porte-paris-10/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-11.html /ouverture-de-porte-paris-11/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-12.html /ouverture-de-porte-paris-12/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-13.html /ouverture-de-porte-paris-13/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-14.html /ouverture-de-porte-paris-14/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-15.html /ouverture-de-porte-paris-15/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-16.html /ouverture-de-porte-paris-16/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-17.html /ouverture-de-porte-paris-17/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-18.html /ouverture-de-porte-paris-18/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-19.html /ouverture-de-porte-paris-19/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-2.html /ouverture-de-porte-paris-2/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-20.html /ouverture-de-porte-paris-20/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-3.html /ouverture-de-porte-paris-3/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-4.html /ouverture-de-porte-paris-4/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-5.html /ouverture-de-porte-paris-5/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-6.html /ouverture-de-porte-paris-6/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-7.html /ouverture-de-porte-paris-7/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-8.html /ouverture-de-porte-paris-8/\n"
+ "https://www.serrurierparis0.com/ouverture-de-porte-paris-9.html /ouverture-de-porte-paris-9/\n"
+ "https://www.serrurierparis0.com/paris-10-depannage-volet-roulant.html /reparation-volet-roulant/\n"
+ "https://www.serrurierparis0.com/paris-1-depannage-volet-roulant.html /reparation-volet-roulant/\n"
+ "https://www.serrurierparis0.com/paris-2-depannage-volet-roulant.html /reparation-volet-roulant/\n"
+ "https://www.serrurierparis0.com/faq.html /faq/\n"
+ "https://www.serrurierparis0.com/faq-percer-une-serrure.html /faq/comment-percer-une-serrure/\n"
+ "https://www.serrurierparis0.com/faq-comment-decaper-une-serrure-rouillee-sans-la-demonter.html /faq/comment-decaper-une-serrure-rouillee-sans-la-demonter/\n"
+ "https://www.serrurierparis0.com/faq-ameliorer-l-isolation-de-votre-porte-d-entree.html /faq/comment-ameliorer-lisolation-de-votre-porte-dentree/\n"
+ "https://www.serrurierparis0.com/faq-comment-remplacer-une-serrure.html /faq/comment-remplacer-une-serrure/\n"
+ "https://www.serrurierparis0.com/faq-installer-un-judas.html /faq/comment-installer-un-juda/\n"
+ "https://www.serrurierparis0.com/faq-decaper-une-porte.html /faq/comment-decaper-une-porte/\n"
+ "https://www.serrurierparis0.com/faq-comment-entretenir-une-serrure.html /faq/comment-entretenir-une-serrure/\n"
+ "https://www.serrurierparis0.com/faq-comment-changer-un-cylindre-de-serrure.html /faq/comment-changer-un-cylindre-de-serrure/\n"
+ "https://www.serrurierparis0.com/faq-poser-un-verrou-de-baie-coulissante.html /faq/comment-poser-un-verrou-de-baie-coulissante/\n"
+ "https://www.serrurierparis0.com/faq-que-faire-en-cas-de-cle-cassee-dans-la-serrure.html /faq/que-faire-en-cas-de-cle-cassee-dans-la-serrure/\n"
+ "https://www.serrurierparis0.com/faq-quoi-faire-quand-la-serrure-est-bloquee.html /faq/quoi-faire-quand-la-serrure-est-bloquee/\n"
+ "https://www.serrurierparis0.com/faq-poser-une-serrure-3-points.html /faq/comment-poser-une-serrure-3-points/\n"
+ "https://www.serrurierparis0.com/faq-que-faire-en-cas-de-cambriolage.html /faq/que-faire-en-cas-de-cambriolage/\n"
+ "https://www.serrurierparis0.com/faq-retirer-les-gonds-d-une-porte.html /faq/comment-retirer-les-gonds-d-une-porte/\n"
+ "https://www.serrurierparis0.com/faq-installer-une-porte-d-entree.html /faq/comment-installer-une-porte-d-entree/\n"
+ "https://www.serrurierparis0.com/faq-changer-le-sens-d-ouverture-d-une-porte.html /faq/comment-changer-le-sens-d-ouverture-d-une-porte/\n"
+ "https://www.serrurierparis0.com/faq-comment-degivrer-une-serrure-gelee.html /faq/comment-degivrer-une-serrure-gelee/\n"
+ "https://www.serrurierparis0.com/faq-comment-ouvrir-une-porte-claquee.html /faq/comment-ouvrir-une-porte-claquee/\n"
+ "https://www.serrurierparis0.com/faq-poser-un-verrou.html /faq/comment-poser-un-verrou/\n"
+ "https://www.serrurierparis0.com/faq-demonter-une-poignee-de-porte.html /faq/comment-demonter-une-poignee-de-porte/\n"
+ "https://www.serrurierparis0.com/en/ /en/\n"
+ "https://www.serrurierparis0.com/en.html /en/\n"
+ "https://www.serrurierparis0.com/it/ /\n"
+ "https://www.serrurierparis0.com/it.html /\n"
+ "https://www.serrurierparis0.com/ru/ /\n"
+ "https://www.serrurierparis0.com/ru.html /\n"
+ "https://www.serrurierparis0.com/mentions-legales.html /mentions-legales/\n"
+ "https://www.serrurierparis0.com/it/mentions-legales.html /it/mentions-legales/\n"
+ "https://www.serrurierparis0.com/en/mentions-legales.html /en/mentions-legales/\n"
+ "https://www.serrurierparis0.com/ru/mentions-legales.html /ru/mentions-legales/\n"
+ "https://www.serrurierparis0.com/tarifs.html /tarifs/\n"
+ "https://www.serrurierparis0.com/trouver-un-serrurier.html /";
final String subst = "RedirectMatch 301 ^$1$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}