using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Parking.*\s.*formula\sfield\s.{9}(.*)<\/span><\/td>";
string input = @"Parking: </span></td>
<td class=""d124m43"" colspan=""5""><span class=""formula field d124m23"">No Garage, Street Parking</span></td>
<td class=""d124m3""></td></tr>
<tr>
<td class=""d124m3""></td>
<td class=""d124m27"" colspan=""6""><span class=""formula field d124m32""><hr></span></td>
<td class=""d124m3""></td></tr>
<tr class=""d124m21"">
<td class=""d124m3""></td>
<td class=""d124m4""><span class=""label d124m23"">Utilities: </span></td>
<td class=""d124m43"" colspan=""5""> <span class=""formula field d124m23"">Central Air</span></td>
<td class=""d124m3""></td></tr>
<tr>
<td class=""d124m3""></td>
<td class=""d124m27"" colspan=""6""><span class=""formula field d124m32""><hr></span></td>
<td class=""d124m3""></td></tr>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}