use strict;
my $str = 'Parking: </span></td>
<td class="d124m43" colspan="5"><span class="formula field d124m23">No Garage, Street Parking</span></td>
<td class="d124m3"></td></tr>
<tr>
<td class="d124m3"></td>
<td class="d124m27" colspan="6"><span class="formula field d124m32"><hr></span></td>
<td class="d124m3"></td></tr>
<tr class="d124m21">
<td class="d124m3"></td>
<td class="d124m4"><span class="label d124m23">Utilities: </span></td>
<td class="d124m43" colspan="5"> <span class="formula field d124m23">Central Air</span></td>
<td class="d124m3"></td></tr>
<tr>
<td class="d124m3"></td>
<td class="d124m27" colspan="6"><span class="formula field d124m32"><hr></span></td>
<td class="d124m3"></td></tr>';
my $regex = qr/Parking.*\s.*formula\sfield\s.{9}(.*)<\/span><\/td>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}