// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Parking.*\s.*formula\sfield\s.{9}(.*)<\/span><\/td>").unwrap();
let string = "Parking: </span></td>
<td class=\"d124m43\" colspan=\"5\"><span class=\"formula field d124m23\">No Garage, Street Parking</span></td>
<td class=\"d124m3\"></td></tr>
<tr>
<td class=\"d124m3\"></td>
<td class=\"d124m27\" colspan=\"6\"><span class=\"formula field d124m32\"><hr></span></td>
<td class=\"d124m3\"></td></tr>
<tr class=\"d124m21\">
<td class=\"d124m3\"></td>
<td class=\"d124m4\"><span class=\"label d124m23\">Utilities: </span></td>
<td class=\"d124m43\" colspan=\"5\"> <span class=\"formula field d124m23\">Central Air</span></td>
<td class=\"d124m3\"></td></tr>
<tr>
<td class=\"d124m3\"></td>
<td class=\"d124m27\" colspan=\"6\"><span class=\"formula field d124m32\"><hr></span></td>
<td class=\"d124m3\"></td></tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}