import Foundation
let pattern = #"Parking.*\s.*formula\sfield\s.{9}(.*)<\/span><\/td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Parking: </span></td>
<td class="d124m43" colspan="5"><span class="formula field d124m23">No Garage, Street Parking</span></td>
<td class="d124m3"></td></tr>
<tr>
<td class="d124m3"></td>
<td class="d124m27" colspan="6"><span class="formula field d124m32"><hr></span></td>
<td class="d124m3"></td></tr>
<tr class="d124m21">
<td class="d124m3"></td>
<td class="d124m4"><span class="label d124m23">Utilities: </span></td>
<td class="d124m43" colspan="5"> <span class="formula field d124m23">Central Air</span></td>
<td class="d124m3"></td></tr>
<tr>
<td class="d124m3"></td>
<td class="d124m27" colspan="6"><span class="formula field d124m32"><hr></span></td>
<td class="d124m3"></td></tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)