$re = '/\b(?:All DLC BG|DLC Comfort)\b(*SKIP)(*FAIL)|\bDLC\b/m';
$str = 'test All DLC BG test DLC Comfort and DLC here
test here All DLC BG All DLC BG BG ALL DLC';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;