// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:All DLC BG|DLC Comfort)\b(*SKIP)(*FAIL)|\bDLC\b").unwrap();
let string = "test All DLC BG test DLC Comfort and DLC here
test here All DLC BG All DLC BG BG ALL DLC";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}