$re = '/This is ([^]*?) sentence/m';
$str = 'This is just
a simple sentence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);