#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:http|ws)s?:\/\/\S*\w\/?"
Local $sString = ""Hello everyone! please join us at: https://oursite.com/. and " & @CRLF & _
"please visit our courses websites: http://courseone.com.eu & http://coursetwo.us. " & @CRLF & _
"For prod use websocket with this url: wss://localhost:4500/websocket/. and " & @CRLF & _
"for staging use this url: ws://localhost:4500/websocket"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")