import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:http|ws)s?:\\/\\/\\S*\\w\\/?";
final String string = "\"Hello everyone! please join us at: https://oursite.com/. and \n"
+ "please visit our courses websites: http://courseone.com.eu & http://coursetwo.us. \n"
+ "For prod use websocket with this url: wss://localhost:4500/websocket/. and \n"
+ "for staging use this url: ws://localhost:4500/websocket\".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}