#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Text\([^)]*\)(?![^}]*?\.appFont)[^}]*}"
Local $sString = "Text("blah") " & @CRLF & _
" .appFont(.body)" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Text("blah") " & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Text(" & @CRLF & _
" "blah"" & @CRLF & _
")" & @CRLF & _
".appFont(.blah)" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Text("blah").appFont(.foo)}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")