import re
regex = re.compile(r"( \[.*\])")
test_str = ("Portuguese B (H13) [1 Teacher & 0 Subject Heads]\n"
"Russian A l&l (S12) [1 Teacher & 0 Subject Heads]\n"
"Russian A lit. (H12) [1 Teacher & 0 Subject Heads]\n"
"Russian A lit. (H13) [1 Teacher & 0 Subject Heads]\n"
"Russian A lit. (S12) [1 Teacher & 0 Subject Heads]\n"
"Russian B (H12) [1 Teacher & 0 Subject Heads]\n"
"Russian B (H13) [1 Teacher & 0 Subject Heads]\n"
"Russian B (S12) [1 Teacher & 0 Subject Heads]\n"
"Russian B (S13) [1 Teacher & 0 Subject Heads]\n\n"
"Physical education [12 Teachers & 0 Subject Heads]\n"
"Physical education (12) [7 Teachers & 0 Subject Heads]\n"
"Sports science [12 Teachers & 0 Subject Heads]\n"
"Sports science (H12) [4 Teachers & 0 Subject Heads]\n"
"Sports science (H13) [4 Teachers & 0 Subject Heads]\n"
"Sports science (S12) [12 Teachers & 0 Subject Heads]\n"
"Sports science (S13) [13 Teachers & 0 Subject Heads]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")