# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"(.*?)"\:(http\S+?(?=\W+(?:$|\s))|http\S+)/[\1](\2)/gm;t' <<< "Cqwertyuioy - Lasgfdf Sddgfdds (Dsajjsa Vsjsjk Osaskgkk Spfs) \"link\":http://www.youtube.com/watch?v=aQjkOmzQ8RT"