use strict;
my $str = 'Cqwertyuioy - Lasgfdf Sddgfdds (Dsajjsa Vsjsjk Osaskgkk Spfs) "link":http://www.youtube.com/watch?v=aQjkOmzQ8RT';
my $regex = qr/"(.*?)"\:(http\S+?(?=\W+(?:$|\s))|http\S+)/mp;
my $subst = '[\\1](\\2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";