# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:food(?: (?:microbiology|safety))?|microbiology and food)\b/<span title="" data-term="T: $&" class="grams">$&<\/span>/gmi;t' <<< "Welcome to MOOC on Food Microbiology and Food Safety. I am Dr. xyz, Coordinator of this course, which is designed under the guidance of Prof. pqrs."