package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(?:food(?: (?:microbiology|safety))?|microbiology and food)\b`)
var str = `Welcome to MOOC on Food Microbiology and Food Safety. I am Dr. xyz, Coordinator of this course, which is designed under the guidance of Prof. pqrs.`
var substitution = "<span title="" data-term="T: $&" class="grams">$&</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}