$re = '/\b(?:food(?: (?:microbiology|safety))?|microbiology and food)\b/mi';
$str = 'Welcome to MOOC on Food Microbiology and Food Safety. I am Dr. xyz, Coordinator of this course, which is designed under the guidance of Prof. pqrs.';
$subst = "<span title=\"\" data-term=\"T: $&\" class=\"grams\">$&</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;