import re
regex = re.compile(r"\b(?:food(?: (?:microbiology|safety))?|microbiology and food)\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = "Welcome to MOOC on Food Microbiology and Food Safety. I am Dr. xyz, Coordinator of this course, which is designed under the guidance of Prof. pqrs."
subst = "<span title=\"\" data-term=\"T: $&\" class=\"grams\">$&</span>"
result = regex.sub(subst, test_str)
if result:
print(result)