// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b(?:food(?: (?:microbiology|safety))?|microbiology and food)\b").unwrap();
let string = "Welcome to MOOC on Food Microbiology and Food Safety. I am Dr. xyz, Coordinator of this course, which is designed under the guidance of Prof. pqrs.";
let substitution = "<span title=\"\" data-term=\"T: $&\" class=\"grams\">$&</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}