import Foundation
let pattern = #"\b(?:food(?: (?:microbiology|safety))?|microbiology and food)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Welcome to MOOC on Food Microbiology and Food Safety. I am Dr. xyz, Coordinator of this course, which is designed under the guidance of Prof. pqrs."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span title="" data-term="T: $&" class="grams">$&</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)