re = /(?<=\/)\d*-[^-]*/m
str = 'p/daphne-logo-espadrille/2208098001-BLACK-38-se.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end