package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\d+`)
var str = `http://host.name/v2/type/44/things
http://host.name/v2/type/44
http://host.name/v2/type/30d-hot`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}